SEO Tools not showing in Ribbon

#1

SEO Tools has been installed, re-installed, and is showing as active in my add-ins, but continues to NOT show in my ribbon, nor are any of the functions showing when I type them in manually.

Im using Excel 2010 32 bit. I just downloaded the latest version of SEO Tools and re-installed it to see if that would fix it, it did not.

Also read on another threat about updating the .NET framework, which is currently up to date.

Just renewed our license as well, but cannot use it now, very frustrating! Please help!

#2

Hi Michael,

It may be because your Excel version is too old (although I believe it was previously supported back to Excel 2007). Another cause is that Excel temporarily disables add-ins to run virus checks. I usually solve this by entering the add-ins menu, click OK, then restart Excel
.bild

#3

I've done this several times, no luck.

#4

Can you try and remove all files from the Connectors folder in the install directory and see if the Ribbon shows up?

Also, is there any chance to upgrade to newer Excel version?

#5

Thanks for the input. I've removed all files from the connectors folder (C/Program Files/SEO tools for excel/connectors/), restarted excel, de-activated and re-activated the addin via excel options. Still no luck.

I suppose I can look into updating excel, but as far as I remember this was working a couple of weeks ago. I don't recall updating SEO tools either, so not sure why it would suddenly stop working.

Thanks again for the advice. Really would love to be able to use the tools soon!

#6

Oh, so it worked previously on Excel 2010 with the same version of SeoTools? Do you remember making any changes before it disappeared?

#7

Nothing that I can think of. We recently renewed our membership, but I don't recall that it broke directly after that, but I can't be sure.

#8

I was doing some VBA work, copy/pasting some functions. Not sure if that could have thrown something off. I see my Solver.xlam add-in in the VBA editor, but don't see SEO tools.

#9

Unfortunately, very difficult to debug this issue. It sounds like it's Excel related however. I have sent you a PM with a link to the latest Seotools build, try if it makes any difference. If not, I recommend upgrading Excel, your version is basically ten years old, so many good stuff have been added!

#10

Thanks very much for your effort on this.

I've installed Excel 64bit, the most up to date version via Office 365.

I completely deleted SEO Tools folder. Re-installed via the most current build you sent me. Still no luck!

At my wits end with this one. Damnit!

#11

Can we do a Teamviewer session so I can debug what is happening on your computer? If so, contact me at victor@seotoolsforexcel.com

#12

i was struggling with it for a much time - finally succeded. Here my blog post about the solution.

1 Like