Problems with Google Search Connector

#1

Hi,
I'm trying to pull some quite complex search terms incl. Google Operators with the Google Search connector and I get only #Value.
I tried with very simple search terms like "test" and I get the same. Any help how I could fix this ?
Thanks !

#2

Have you updated to the latest version from the Manager?
https://seotoolsforexcel.com/manage-connectors/

The query part is a bit confusing because the "site:" operator is not supported because it's moved to the "Domain" text box. Will remove this text box all others related to queries to have the entire search string in the Query text box.

#3

Yes I have the latest version.
It doesn't work even with quite simple searches (see screenshot)
Thanks !

#4

It should work, see below:

If you click on the "About" icon, what does the path say to seotools.config.xml? You may have outdated references to your connectors.

If we can't solve this, contact me at victor@seotoolsforexcel.com and we can do a Teamviewer session and I can debug what is going on on your computer.

#5

Hi,
this is strange. It did not work in my case so I switched of proxies and Delay to test.
It worked.
I switched on again proxies and now it works.
What could be the reason for the previous error?

#6

Now I get errors again

#7

Sounds like it is related to the proxies. I think Google adjusts the results depending on the location of the proxies. Can you test and determine if one proxy fails each time? If so, can you email the proxy so I can look at the html response?