PhantomJS Cache Not Working

#1

I recently switched from using SeoTools 8.0.70 to 8.1.25. When using PhantomJsCloud.XPath with Cache=True, different xpaths (ex: title, canonical, etc) are correctly returned for the same URL. However, the connector returns the same result for each xpath across different URLs. When Cache=False, it works correctly. I see the same behavior whether inserting formulas or values.

I've confirmed that the previous version of that connector works as expected, with or without cache. The previous version (included with SeoTools v8.0) used PhantomJS v1 API which also required a Location parameter.

Is this a bug in Phantom's v2 API, or is it a problem with the connector?

#2

Hi,

Do you mean the Cache checkbox inside the PhamtomJS connector? It might be because the URL parameter was in the request URL (older version of PhamtomJS API), but now it exists in the request POST body.

Not sure which version of the connector exists in the 8.0.70 version. Can you check if the connector code is different in this way:

New:
image

Old:
image

#3

I mean the actual result is the same across multiple URLs. Whichever URL is cached first, that result gets carried over to other URLs. This screenshot shows some examples:

My new and old versions of the connector match the same code that you're showing. I've versioned the old connector based on its original date stamp and it's archived here.

#4

Thanks, I've tested and the issue is because only the URL gets cached.

I've changed the request to GET type which PhantomJS supports. I've emailed you the updated connector file.