Nothing works - just #value for all queries


#1

Win7 x 64
Excel x 64 - Office 365, Version 1808, Build 10730.20127
STFE - 8.0.28.0_20180828 and 8.0.36.0_20181003

Any STFE query (title, desc, canonical and so on) ends up with #VALUE, not dependently on the data type of the cell (standard, text, number...) Tried to get same data with XpathOnUrl - same fail, only #VALUE for everything.

Some further infos:

  • It seems, that the problem begins with the last Office update,
  • Even realized, that installation of 8.0.36.0_20181003 has choosen /Program Files (x86)/ for installation, not /Program Files/, as expected for x64

#2

Hi,

Are you in some kind of Office developer program to get beta updates? I also have Office 365 and it says version 1803 is up to date.

Installing to Program Files (x86) is default, regardless of 64 or 32 bit, so I believe that is not the issue.

Do you have the possibility of reverting the version back to the previous?


#3

Both questions - no :frowning: No any beta installed, no possibility to revert. I get Office through internal firm network rollout - so no betas and no influence on the installed version.

After full deinstallation and clean installation of the current version (all saved data deleted, was forced to input register data again), i get the same effect - no single query is possible, all queries end up with #VALUE, but i get now an error. The error is the same for all queries, there is it:

htmlTile:
stfe-error-htmlTitle

htmlMeta
stfe-error-htmlMeta

htmlCanonical
stfe-error-htmlCanonical


#4

After Office update to Version 1809, Build 10827.20138 STFE works again!


#5

Great! I was just about to ask you if you were willing to use Fiddler and capture the raw request/response to identify the cause :slight_smile:


#6

what do you mean to the fired errors? Looks like it was something wrong with windows line endings...? Or is the error text not as exactly meaningful?


#7

I wanted to capture the requests to get a better idea of what was going on. Never seen that error message before.


#8

Now comes the error again: only #VALUE, no data... Can't use STFE since a month not normally, grrr...
STFE: SeoTools_v8.0.70.0_20181101
OS/Office: Win7x64, Office 365 Business, Version 1810 (Build 11001.20108)

err


#9

Can you email me a print screen of the About window? Also, what types of formulas/functionality produce that error message.


#10

Any function, bot of formula or through addon GUI.


#11

Please try and delete the Seotools for Excel folder in the \AppData\Local folder while Excel is closed. The config path should reference the install path afterwards.


#12

Same error after deleting. About looks now like


#13

Is it the same for all Urls or are you making requests to Incapsula.com or other related sites?


#14

For any URLs - don't ever know, what is Incapsula...

After deleting Seotools for Excel folder in the \AppData\Local folder i get an error on any start of Excel "The folder with configuration of SeoToolsForExcel isn't writeable"


#15

Sorry to hear this. I was thinking it was related to the specific error message you posted:
https://social.technet.microsoft.com/Forums/en-US/b10b16d1-8eea-4b52-8aeb-f96ea87135fa/sectionresponseheader-detailcr-must-be-followed-by-lf?forum=powerquery

I recommend uninstalling, deleting all references, and re-install Seotools. Did anything change on your computer/network before the issue started?


#16

The first time the issue appeared after an Office update. There was no solution, but with the next Office update the issue was gone. But with the next Office update it was coming again...


#17

No success. After clean install the same error.


#18

Sorry to hear this. Sounds like it is related to the Office updates which triggers some setting.

If I remember correctly, the updates were rolled out on an office level in your workplace? If so, can you ask IT was may cause this behavior?


#19

I can't explain to my IT, what exactly triggers an error. The only hope is they will downgrade my Office and don't begin talking about firm guidelines and security and so on...


#20

Tried to install the latest STFE (SeoTools_v8.0.70.0_20181101) on another computer - a virtual machine, running on another hardware, than mine, with another OS (not Win7x64, but Win10x64) and another Office (not x365, but 2010, 14.0.7224.5000 x 64) - and got the same error:

Something is really buggy. Downgrade is also not a solution...

Trying to get any data by spider ends up with #VALUE too.