Not really a bug, but annoying and weird thing: formula MUST contain a line break to work

#1

I'm on Win10x64, Excel 1908, Build 11929.20254, STFE 8.0.90.

My goal is to query GSC data with multiple filters page == and query !~. Added both filters to the filter field in the sidebar of GSC settings they work like expected.

My further goal was to get metrics for multiple urls - for this i was needing the formula. I generated the formula with STFE, which worked too.

I've copied the formula into my text editor and realized, that there are three line breaks within. I've deleted them, tried the formula - doesn't work, just zeros instead of numbers. It is understable, why it doesn't work - because the second filter begins immediately after the first.

Finally i've got it to work with a single line break, just before the second filter. But this is very very bad workaround, which is absolutely useless for my scaling goal - because wenn i have a line break in the formula, i can't paste it into a cell with ctrl+v and get metrics. On this way the formula is pasted into two cells, because of line break - and surely doesn't work.

Could you please please make it so, that the separator of filter operators and their criteria becomes a sign, like a pipe? But not a line break, and not a tab - because this makes ctrl+v no longer possible...

Examples:

#2

Hi, this is by design (using new line to separate filters). However, you are correct that it messes with copy pasting the formulas.

I recommend you editing the connector file, line 62, change from '\n' to ','. Then you can use comma to separate the filters: