Google Indexing API

#1

When I first used the indexing API with the connector the first URL worked as expected and returned a URL Updated notice.

When I went to do the other URL's on my sheet (11 in total) this popup showed up: https://share.getcloudapp.com/OAuqlOKj

Since I haven't used the API in any other tool and I only submitted one URL successfully, I assume there is a bug somewhere or something that I'm doing that it causing it.

Has anyone run into this issue and how can I correct it?

Update: I can change Google accounts and connect and do one URL. After that URL I run into the same message about exceeding the quota.

Perhaps a work around is to change the account set up to use the API key and creds versus the OAuth to ensure users can leverage the API?

#2

This is because Google has decreased the limits for our app and currently, all users share 260 requests per day:

I have applied for higher limit, hopefully will get approved.

#3

So would it be possible to change the connector so we can use our own API credentials?

#4

Yes:

  1. In the Google API Console, click "Create Credentials"
  2. Chose "Oauth Client ID"
  3. Chose "Desktop App"
  4. Chose a name and create the app
  5. Copy the Client ID and Client Secret
  6. Open GoogleIndexing.xml, located in the folder "Connectors" in the SeoTools install directory
  7. Paste the Client ID and Client Secret to the empty attributes in the tag GoogleOAuth2Authenticator at the top
  8. In SeoTools, chose "Reload Settings" under Settings
  9. Open up the Google Indexing connector, sign out then sign in again and authenticate your own app.

Let me know if this guide is unclear. I will probably add this as a guide with print screen examples to the Google Indexing documentation page.

#5

Will do, I'll go through the process today and let you know!

Thank you

#6

Verified, works like a charm.

1 Like