Google Analytics Login stopped working

#1

Starting today, when I hit the "Google Analytics" icon and then the "Login" button...I get the hourglass for about 10 seconds....then nothing. I hit it again and not even that happens. If I quit excel and restart Excel, it starts fresh and I get that 10 second wait after hitting the button....then nothing again. It's like it's trying to bring the browser up for authentication but can't.

I upgraded to the current version and rebooted my machine; same results.

The only thing I can think of is, maybe there was a Java or Browser or .NET upgrade?, I have Firefox, IE, and Chrome set to auto upgrade themselves.

Is anyone else having this experience?

Is there a log somewhere I can examine for some kind of error message?

What should I tell my IT people, this is not an application or service, it just runs under Excel, if it's a Firewall issue should I tell them to not block Excel? There's some real basic questions there that ought to be in some kind of faq, I have not seen anything on this in various searches of this forum, they're pretty fundamental connectivity questions (!)

Below is the top part of my config file if that's of any help - Thanks in advance! - Ted

(Sorry, I had to replace < and > with $$$ everywhere or these lines all paste crazily into this text editor, it's like it tries to intepret the XML):

$$$?xml version="1.0" encoding="utf-8"?$$$
$$$SeoTools CheckLatestVersionOnStartup="true" ShowStartWindowIfPro="false"$$$
'
' $$$!--
' Note: Restart Excel after changing this file!
' --$$$
'
' $$$!--
' $$$SqlConnection ConnectionString="Data Source=;Initial Catalog=;Persist Security Info=True;User ID=;Password="/$$$
' --$$$
'
' $$$ConcurrentRequest$$$300$$$/ConcurrentRequest$$$
' $$$ConcurrentHostRequests$$$10$$$/ConcurrentHostRequests$$$
' $$$RunAsyncUdfsSynchronously$$$true$$$/RunAsyncUdfsSynchronously$$$
'
' $$$Errors$$$$$$Rule MatchFunction="" MatchException="" ReturnValue="#VALUE!" ShowMessage="true" /$$$$$$/Errors$$$
'
' $$$!-- $$$Connectors Api="http://localhost:55322/" WizardPath="%home%\connectors"$$$--$$$
' $$$Connectors Api="http://connectors.seotoolsforexcel.com/" WizardPath="%home%\connectors"$$$
' $$$Paths$$$
' $$$!--$$$Path$$$$$$/Path$$$--$$$
' $$$/Paths$$$
' $$$/Connectors$$$
'
' $$$!-- Note: Changing these settings affects most functions in SeoTools! --$$$
' $$$HttpDownloader$$$
' $$$GlobalSettings$$$
' $$$Cache$$$true$$$/Cache$$$
' $$$IntervalBetweenRequests RandomFrom="0" RandomTo="0" IfSame="Host" /$$$
' $$$FailOnHttpError$$$false$$$/FailOnHttpError$$$
' $$$CollectCookies$$$false$$$/CollectCookies$$$
' $$$RequestMethod$$$GET$$$/RequestMethod$$$
' $$$RequestEncoding$$$UTF-8$$$/RequestEncoding$$$
' $$$ResponseEncoding$$$UTF-8$$$/ResponseEncoding$$$
'
' $$$!--
' $$$RequestMethod$$$POST$$$/RequestMethod$$$
' $$$RequestContentType$$$application/x-www-form-urlencoded$$$/RequestContentType$$$
' $$$RequestForm$$$
' $$$Param Name='Foo'$$$abcÅÄÖx$$$/Param$$$
' $$$Param Name='Name'$$$Niels Bosma$$$/Param$$$
' $$$Param Name='Url'$$$http://foo.com/bar.aspx?x=y&c=d$$$/Param$$$
' $$$Param Name='Html'$$$<a href="/foo.aspx">bar</a>$$$/Param$$$
' $$$/RequestForm$$$
' --$$$
'
' $$$RequestHeaders$$$
' $$$Header Name="User-Agent"$$$Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko$$$/Header$$$
' $$$!--$$$Header Name='Accept'$$$text/html$$$/Header$$$--$$$
' $$$/RequestHeaders$$$
'
' $$$!--
' $$$Proxies$$$
' $$$Proxy Address="" User="" Password=""/$$$
' $$$/Proxies$$$
' --$$$
'
' $$$!--
' $$$AuthenticateUser$$$$$$/AuthenticateUser$$$
' $$$AuthenticatePassword$$$$$$/AuthenticatePassword$$$
' --$$$
' $$$Timeout$$$120000$$$/Timeout$$$
' $$$/GlobalSettings$$$
' $$$/HttpDownloader$$$
'
' $$$GoogleAnalytics OAuthClientIdentifier="" OAuthClientSecret="" StayAuthenticated="true"$$$$$$EncryptedRefreshToken$$$AQAAANCMnd8BFdERjHoAwE/Cl+sBAAAAAbE63K0YHU2zc4s+RiBOFAAAAAACAAAAAAAQZgAAAAEAACAAAABjaczxMu3eURT4sUhPPbXnSS52tHO2qOZrCfOUJ4S6QgAAAAAOgAAAAAIAACAAAABU1Wts6gNCc5fAJuCUedSd7aD65B2VU8OpML1zMkUUnfADAACzUxAweZBUyh3EPfq3uVy14B4t3pvfRu74tNoO/8ZMttPCSm868ZPW02saO4hR2b34sN2+3o3gz2qRARXAjtys2wDXpKg7J3MT3v+NqmPu5Cr3tyAjp5itlqOc5m9/3bAdJevUM415cQMsBkF+KMw2IL8xKPVjOhyHvc/hdmiJ2f1pyRj7WVD5u/jiddmiOBde8qJWbZq1IQJ5zG2tnFgTcEH0AOGflcd32wc+0hmNRW7o5PKrJ9G6wk1fBzPO/XsZ+SywrMVfXPlWBaaQCCU7aAMWU5sUQWLirsjcy8qwaejdARwJ48DJ6M83Ye7mYdtF1+nedBHRv3ZiA+nOOe27tdI9cI8oQS8QsakzyLoziyBO9T8EzIDXDsfkCNYPepaH006vfF7WLBzsIxROQCNIoT6mWgIXbidNrMQumrese0PBNjBQWN0nWB51EThSVkA4Vlxrsr0+kdnaGUMmyFP3L8NcBRDsQYeKOtMgREkDyNBa7NJz0r1JohbhfjVqz8ezYVyUJXs9HI9hehoUFvt/JPgf6yHxPbun0ZND+YW42QMSl+mBo5haczBRKrIIJq7+QJ89XbaJsapxOayoU7D5DQSMdYH4907bTWjhD0F4DtQMsZ+/9S3vpVhQSn7EHKCia8/+5FTkJcdcL5E9JeeUmYvrQ1i9bwXTT4Z4KtY9PLFyzd4G394S2vAyAszKxnUzQW8Ljn4E96j+6YuI6VKmeIQED1876uB0dCKIkv11/4ZpxQkPW46cLZD11lVLAVUyDHcvrFpXNsAjtaJSX7PquWSKZdk1xNxRpDtkj+o41GzUCOtFggKBS/gyUbN/z1f//RNGREjx8YCGh6KgtsImXtgWnbv0qMCzTVMp67kfAItH40x+9Fc5ADC9TPs0xxfT6g944uOoi4vhTnEHe7aXALSpz1eyf6Oq4Yi8NPmmP+uVDSQY8o3mNpe5Bx0AG3jiMrV+5+vzVmCqVTswy59dzzNjDhb9SaG9uS+vAhXqwCldBAUPqxYUky1qSkD1AtunWiTJ6WpoJdjM0dC1QEvKK5RHudfK/x63e8m5Tg4PpW7UYTTzAGjDSaf88c9Upq98SKb08Xa66tdrEpEAJM/ztgZlGJABq0m5wpNBl0KWg5KMXoV2U2iHftGJGgoZMlTzf3aDcFlHBLTLAozuG8Z2mCZDVlFly9habvKWcg60f/mtXR9k8wPjE0tJoAFoGhkc43LrfZ73PF99TMxqb3WPwkMEF3nZG6WNJYZUMB+TiI3qTolFs10eBeTInrtGXIDQkAUcrZ1cN4wNb8rAeECzCSmi5FLx18/1qfJYZITf/nlRROhADZK4cqNLSWJ6nLRAAAAAET6E+qOqyzaZwsjNwgNoPL9+1W/X3cmtOLgrDtiSzcrFhrWDFKxAvthkNESgs1ZAz9Hgm+4Sag0lWondbqTS+Q==$$$/EncryptedRefreshToken$$$$$$/GoogleAnalytics$$$
'
' $$$GoogleAdwords OAuthClientIdentifier="" OAuthClientSecret="" StayAuthenticated="true" /$$$

#2

Google Analytics use localhost for authentication (client-side). Maybe you can ask your IT-department if this may cause the behavior. If possible, I can lookup the specific ports used.

Before that, I would try and delete the GA tag from your config file (while Excel is not open) which will force a new authentiction.

#3

I changed it to:

$$$GoogleAnalytics OAuthClientIdentifier="" OAuthClientSecret="" StayAuthenticated="true"$$$$$$EncryptedRefreshToken$$$$$$/EncryptedRefreshToken$$$$$$/GoogleAnalytics$$$

...still doesn't work...if you could look up the ports I'd like to try to doublecheck whether they're blocked by the firewall.

Are there any logs one could use to debug this behavior?

#4

I just checked and we don't specify port. May I ask why you include the dollar-signs in your pasted tags? Is that some kind of auto-formatting?

I would try and remove the tag completely, and also install newest build:
https://releases.seotoolsforexcel.com/SeoTools_v8.3.0.5_20200206.zip

#5

I will try that.

I had to replace the greater than and less than signs in what I posted (I chose $$$) , because it's XML and this editor in the forum interprets the XML and presents it crazy! It's not like that in my config file lol

#6

Hey, thanks for the advice, I did a complete uninstall, clean reinstall of that newest build, and it works now! Awesome thx!

1 Like