Canonical Not Working

#1

I'm trying to run a report and get canonicals on some URLs but i keep getting this message. Is there something I'm doing wrong? I've used this multiple times before with no issues other than being a little slow.

#2

Hi,

Can you supply a list of URLs you are targeting? Is it always the same URLs which generates this error message?

#3

Yeah I've tried several different URLs and it's not working when I have a list of URLs and try to add the canonical on afterwards. It works if i have it selected in the spider but if i'm crawling thousands of URLs having the canoncial can really slow down the tool or wig it out.

#4

That is not really helping me track the cause of your issue. Can you answer the two questions?

#5

Column B canonical was done when using the spider at the same time. Column C was done individually after the spider has already ran. You can see cell C2 =HtmlCanonical(A2)

I've tried a couple different websites and I'm running into the same thing on each site. This has been working for me up until last week when it just randomly stopped.

#6

Hi, RJ. I couldn't replicate your problem, as HtmlCanonical() works as expected on those URLs for me. Try this alternate method using XPath:

=XPathOnUrl(A2, "//link[@rel='canonical']", "href")

#7

I'm trying other functions and keep getting an error now. Does this picture help? Can i reset seotoolsforexel back to factory settings?

#8

You can try to Reset HTTP Settings:

Easiest way is perhaps to do a clean install and remove any previous references to SeoTools.

#9

I'm still having issues. I've reinstalled it and thought it was working but still having the same problems. I also did the reset settings like you showed above. What should I do to get this to work? Other people on my team aren't having problems with the tool, so it's something with with my computer/download.

Thanks,
Richard

#10

Does other formulas behave the same or is it just HtmlCanonical? Can you provide your email and I can send you a beta version to see if it works better?