Not installing on my PC


Hi Kenneth,

Can you email me at and I'll send you a newer build?



Having troubles installing onto pc win10, excel 32 bit.

When I extract v8.0.90.0 i get the install file
when opening i get a security warning
When i run anyway 2 screen open:

  1. seotool for excel setup
  2. seotool for excel set up was interrupted

When i try to install it gives me the following message:
Seo tools for excel setup ended prematurely because of an error, etc.

Before I can complete the install it also comes with a user control issue (no security certificate for the app etc.)

I tried to install with admin rights but windows does not show the option even when i enable it via command prompt or when i try to install as admin via command prompt.

Any other suggestions? Perhaps you have an older or newer version i could try?


ps tried to disable windows defender etc. but no difference.


Replied to your email. Let us know if it works.


Yep resolved now, downloaded 64bit excel instead of 32 and works fine now.


I am also having this issue.

Win10 64bit on .net 4.7.2
Office 2007 Pro plus 32 bit


Installing; SeoTools_v8.0.90.0_20190121.msi with admin rights.


Hi Kalidor,

Send me an email and I'll provide a link to a custom build with new install method.


I'm having the same 'setup ended prematurely' issue. Can you help? This looks like it would be an awesome add-in if I could get it to work. Email is Thanks!


Emailed! :slight_smile:


I have also emailed you, please send me asap


I have the same issue and don't manage to install the plugin...


Sent you a PM with custom build.


Hi there!
Same issue on my pc.
Thanks for your help
e: pafontanel at


Sent you an email with custom build.


Hello there!
Yesterday I downloaded the plugin and have since been trying to install it on my Win 7 Ultimate 64-bit machine with Office 2013 64-bit EN and encounter the same issue.

Why is it necessary to send custom versions to all the users reporting issues here? Why can't you just fix and deploy a compatible version instead?

Kindly provide me a working plugin.


Because the problem appears to be related to Excel installed via Microsoft Store and this issue is not fixable. Requires install via regular add-ins menu. Here is a link to 64-bit non-installer with necessary files:

Will add support links to make it easier when next version is released. Contains checks during install to identify the issue and provide instructions.


Thanks for the immediate reply and the file provided. I installed the plugin via Excel options > Addins menu and received the following dialog afterwards.

Kindly tell me what that means and what to do.



Never seen that error before. Also never seen the install error for 64-bit Excel. If you are willing to let me debug your computer via Teamviewer, send me an email (


Thanks for that offer. Unfortunately I can't provide access to this computer, as it runs in a VM within a corporate environment. But mabe you can tell me whether I made a mistake when unzipping your archive and installing the plugin from within Excel via selecting the file SeoTools64.xll from the extracted archive? I didn't install plugins before and just tried to manage installation from my intuition and experience.


That should be the correct approach. Is there any security within your VM/corporate environment that would block you from installing add-ins?


I have full access to the VM and can manage installations in there with admin rights. However, the VM has no Internet access. After talking to our head of IT I received a list of suspicious activity the MSI is supposed to apply on/after installation. This list was handed over to me by him after checking the MSI with the help of Sophos Sandstorm. Maybe there's a relation to the missing Internet access?

Maybe you wanna state something regarding the suspicious activity mentioned?

• Office performs a HTTP download
• Reads data from the local Windows system configuration
• Tries to access unused Windows system drive letters
• Office application uses DDEAUTO
• Excessive number of file write operations by a process

• Changes the permissions of a memory region used by system libraries

It has been argued that this should not be part of the expected regular functionality of this plugin.

(Hope I could clarify everything no matter how poor my English is)